breaking point with my 250f

jaakee_
Posts
74
Joined
7/11/2013
Location
NV US
10/18/2017 8:03pm
About a month ago, i noticed shavings in my oil filter. Immediatley tore the whole engine down, and did a full rebuild on the motor. Top and bottom.

The problem i face now is i am getting lots of coolant coming out of my weep hole under the water pump on the right side. A leaking head gasket would add pressure to my radiators thus causing it to over heat. However no coolant comes out of the overflow.

I replaced the water pump seal again and fired it up only to get the same problem. Im leaning towards the shaft seal. Input?
|
ktm-5
Posts
522
Joined
2/17/2017
Location
Ravenna, MI US
10/18/2017 8:43pm Edited Date/Time 10/18/2017 8:43pm
Did u replace the seal on the water pump cover? Also make sure there were no burrs or anything?
dirtmike86
Posts
1106
Joined
10/28/2015
Location
Grand Terrace, CA US
10/18/2017 9:07pm Edited Date/Time 10/18/2017 10:15pm
Did you put the a new seal in? If so did you put the seal in backwards? Sounds stupid but ive seen it plenty of times.
garagedog
Posts
731
Joined
4/23/2014
Location
Tulare, CA US
10/18/2017 9:42pm
Replace shaft and bearings too. Bad bearings allow the shaft to wobble a little causing the seal to wear quickly.
Paw Paw
Posts
679
Joined
12/24/2011
Location
Benton, LA US
10/19/2017 7:03am
Water pump rebuild is needed.

Paw Paw

The Shop

Acidreamer
Posts
1728
Joined
8/25/2015
Location
Mansfield, OH US
10/19/2017 11:20am
Paw Paw wrote:
Water pump rebuild is needed.

Paw Paw
X2.
10/20/2017 5:17pm
are you 100% positive its not the head gasket? Thats what i would try next.

Post a reply to: breaking point with my 250f

The Latest

The Latest