YZ250FX running hot

Related:
Create New Tag

9/2/2018 6:59 PM

My FX seems to be running hot lately. I recently installed a new fuel pump. More popping on decel lately and the fan is turning on a lot quicker than it usually does. I have not checked the plug yet. Coolant level is fine, it never boils over or pukes coolant. Just seems to be running hotter than it normally does. feels a little lean.
Any ideas?

|

9/2/2018 7:02 PM

TPS would be my first guess

|

9/2/2018 10:57 PM

Choke?

Clogged fuel injector?

Fuel filter?

|

9/3/2018 5:45 AM

kb228 wrote:

TPS would be my first guess

How can you tell it’s TPS?

|

9/3/2018 5:46 AM

CarlinoJoeVideo wrote:

Choke?

Clogged fuel injector?

Fuel filter?

Could be the injector. I put a new pump in recently but didn’t replace the filter, just cleaned it out. I run a filter sock in my tank.

|

9/3/2018 5:47 AM

kb228 wrote:

TPS would be my first guess

Tuna wrote:

How can you tell it’s TPS?

You just check the voltage at closed and open throttle. If its not to spec it will cause the bike run lean or rich. decel pop means its running lean and running lean causes heat issues.

|

9/3/2018 9:24 AM

kb228 wrote:

TPS would be my first guess

Tuna wrote:

How can you tell it’s TPS?

It's not the thrttole senser.

|

9/3/2018 4:35 PM

kb228 wrote:

TPS would be my first guess

Tuna wrote:

How can you tell it’s TPS?

imoto34 wrote:

It's not the thrttole senser.

??

|

9/3/2018 5:02 PM

Can also be a plugged injector as well. I was more or less saying my first suspect would be the tps. The constant vibration and shock can throw them off.

|

9/5/2018 5:52 PM

Plug looks fine, doesn’t look lean. Photo
Photo

|