What happened to this piston ?

Related:
Create New Tag

6/5/2021 9:14 PM
Edited Date/Time: 6/5/2021 9:15 PM

2009 KX450
Rebuilt top end, shimmed valves, new timing chain and cylinder cleaned up with a hone.

Had roughly 6 hours on new piston. Oil changed after about 4 hours.

Pro X piston Btw Photo

|

6/6/2021 5:26 AM

Oil filter in backwards?

|

6/6/2021 6:12 AM

Possibly, I know the guy changed the oil right before this happened.

|

6/6/2021 4:41 PM

Broken Impeller

|

6/6/2021 7:09 PM
Edited Date/Time: 6/6/2021 7:11 PM

Factor E wrote:

Broken Impeller

I hope not, took it apart for the previous rebuild and the impeller was broken off.
I don’t have a clue how long it was broken for but it was definitely broken for a while judging from the gouges in the housing. This photo was after I cleaned it up with a dremel. Photo

|

6/6/2021 7:13 PM

Here’s what the broken impeller and housing looked like. Photo
Photo
Photo
Photo
Photo
Photo

|

6/6/2021 11:12 PM

Usually with a backwards oil filter and starving the engine of lube the head goes first (the furtherest point before oil returns).

|

6/7/2021 7:17 AM

Looks like piston had massive lack of oil. Maybe the oil squirter jet under the piston got clogged ?

|

Powerband in every gear !

6/7/2021 5:15 PM

Was there coolant in the radiator when you drained it?

|

6/8/2021 7:04 AM

Yes it was full of coolant. Looked dirty when I drained it though.

|

6/9/2021 6:14 PM

LuiesMaes wrote:

Yes it was full of coolant. Looked dirty when I drained it though.

From all the metal in it.

|