RM 125 mid range bog

Related:
Create New Tag

8/12/2018 5:50 PM
Edited Date/Time: 8/12/2018 5:51 PM

Got a 2002 RM 125 that’s throwing me for a bit of a loop. Runs fine on bottom, seems okay on top, but 1/4-3/4 throttle it sputters and smokes when you rev it on the stand, and riding it, it won’t pull past there.
What I’ve done:
Rebuilt carb- stock jetting, 460 main, 32.5 pilot, needle in the 3rd clip, 5mm float height.
Checked compression- 125 psi
Checked powervalve- moves freely, freshly cleaned
New oem spec spark plug.
Ran it with the kill switch unplugged to eliminate that vibrating and causing it

I did run it with the powervalve cover off to make sure it was actuating, everything moves freely, but it does seem to jiggle around a bit so I’m thinking maybe tension spring? Or is there some trick to clocking it correctly? It had been messed with previously so I don’t have a baseline to go from.
Thanks!

|

RPM Performance
CT
783

8/12/2018 6:19 PM

That's pretty low compression number...have you checked reeds? Pull mag cover to check for bad crank seal, grab flywheel & see if it moves in/out, up/Down, any movement is crank bearing wear. Smoking could be rt side crank seal sucking gear oil...just some suggestions...

|

8/12/2018 6:50 PM
Edited Date/Time: 8/12/2018 6:51 PM

Very low compression.
And yes the exhaust valve spring needs to be correctly.

Paw Paw

|

8/12/2018 7:20 PM

I’ll recheck that compression number tomorrow, maybe I read it wrong, top end is all fresh. I’ll sneak a peak at the flywheel/crank seal too. Paw Paw, as far as getting that exhaust valve set, what am I looking for? I can get a video of the vibration too if that helps.

|

RPM Performance
CT
783

8/14/2018 7:28 AM

There are videos on youtube on how to set that spring. The manual also has that info.

Paw Paw

|