KTM SXF 450 2016 Stalling

Related:
Create New Tag

4/28/2018 7:11 AM

Long story short bike stalls at random while riding, usually on slower parts of the track when I am not that hard on the throttle. It stalls just as if I hit the kill button.

Has anyone had these problems? Plan is to strip the bike tonight and check everything.

|

4/28/2018 7:15 AM

Im dealing with that on my kx450 right now. I changed my filter, injector, fuel pump, checked valves, and still cant figure it out. Decided it was beyond my knowledge and took it to a local guy here who knows everything like pawpaw does lol. Good luck finding the problem.

|

4/28/2018 7:37 AM
Edited Date/Time: 4/28/2018 7:46 AM

Forgot to mention it stalled 5-6 times during a 30 minute moto.

|

4/28/2018 8:07 AM

Have you turned up the idle?

Check the inline fuel filter, might be dirty and just need a new one.

|

4/28/2018 8:20 AM

CarlinoJoeVideo wrote:

Have you turned up the idle?

Check the inline fuel filter, might be dirty and just need a new one.

I have not touched the idle yet.

Will do. Worth mentioning is that the condeser is brand new so that can be ruled out.

|

4/28/2018 9:24 AM

If you just had the bike apart (saw your build thread) make sure all the electrical connections are fully snapped together and that all the grounds are clean and tight, especially by the battery. And i would pick up a few of the inline filters that go by the quick connect. Theyre cheap. I keep a few in my toolbox and change them periodically.

|

4/28/2018 9:46 AM

TPS adjustment for sure!

|

4/28/2018 10:22 AM

JBoneMotorworks wrote:

TPS adjustment for sure!

x2

Paw Paw

|

4/28/2018 10:56 AM

Thanks for the tips guys, is there any easy and quick way to adjust the TPS? I have no idea how to and neither does my mechanic (dad haha).

What would be the "correct" TPS? Can't find anything in the owners or service manual.

|

4/28/2018 11:04 AM

This needs to be donw with either a multi meter and or a self powered meter like from www.ktmandhuskyparts.com you basically need to get the intitial voltage reading and advance the TPS sensor for a very slight increase in voltage to remove the stutter off idle. Youtube has some videos of it.

|

4/28/2018 1:17 PM

About .5 -.6 volts at idle on the TPS.

Paw Paw

|

4/28/2018 8:52 PM

I have maybe found the problem, I will report later today if it works or not. Ran a 20 minute moto last night (9-10 isch so had limited time) and am on my way back to the race so hopefully it works.

|

4/29/2018 9:20 AM

Gonna bump this as I found the problem.

The rollover sensor was faulty and made the stalling happen, tested the one from my 350 and the bike works awesome now!

|