A lot of oil left over in 2 stroke cylinder? HELP

Related:
Create New Tag

2/2/2019 9:07 AM

Pulled my cylinder off to do a top end and oil lines the inside of the cylinder and my ports, underneath the piston, and on top of the crank cases in the groove that the cylinder sits. What could be the cause? My gasket was also soaked in oil. Running to rich? Bad crank seal causing the transmission Oil to be placed up top? Gasket leaking? Also had some water underneath the power valve cover. Wondering if it was leaking and got water in there and caused a “sludge” like substance with the premix. Opinions? I have photos but don’t know how to upload them

|

2/2/2019 9:09 AM

Also one of my cylinder studs was rusted bad. Another reason why I think one of the gaskets may have been leaking. 25 hours on top end

|

2/2/2019 12:30 PM

combination of a gasket and running to rich

|


Thanks to- Monster energy, Mika metals, DT-1 filters,Factory connection, works connection, factory effex,acerbis,O'Neal,Scott,Hann wheels,Maugra USA, Engine ice,Slick products,Leatt. Yes me sponsors are real.

2/2/2019 4:41 PM

Does the oil color match your premix oil or transmission oil? There should be some oil coating everything.

|

2018 KTM 250sx
Instagram CamaroAJ

2/2/2019 7:44 PM

brody wrote:

combination of a gasket and running to rich

That’s what I’m hoping

|

2/2/2019 7:45 PM

AJ565 wrote:

Does the oil color match your premix oil or transmission oil? There should be some oil coating everything.

I run yamalube so it’s dark purple, I run rotella 15-40 in transmission. The stuff under the piston and everywhere is black. Could be dirty Tramission fluid or dirty premix

|

2/2/2019 7:49 PM

can you post some pics of piston and crank

|


Thanks to- Monster energy, Mika metals, DT-1 filters,Factory connection, works connection, factory effex,acerbis,O'Neal,Scott,Hann wheels,Maugra USA, Engine ice,Slick products,Leatt. Yes me sponsors are real.

2/3/2019 9:35 AM

brody wrote:

can you post some pics of piston and crank

I don’t know how to post pictures. I click on photo and add the photo but then nothing adds. It doesn’t do anything

|

2/3/2019 9:36 AM

Photo
Photo
Photo
|

2/3/2019 9:58 AM

looks like a combination of some piston blow by, piston is not sealing correctly, and maybe a bad gasket in the bottom, it looks like that is rotella on the bottom of piston and the crank

|


Thanks to- Monster energy, Mika metals, DT-1 filters,Factory connection, works connection, factory effex,acerbis,O'Neal,Scott,Hann wheels,Maugra USA, Engine ice,Slick products,Leatt. Yes me sponsors are real.

2/3/2019 5:23 PM

I find it hard pressed to not be a crank seal to get that much oil and I'm sure it won't look like either oil being they are mixing together in the crank case and I've seen studs just as rusty and have no issues. I do clean them up when I tear it apart and if you'd like to do the same, take 2 nuts and tighten them to each on stud then use bottom nut to unscrew the stud

|

2/4/2019 2:49 AM

Does your bike smoke too much and burn transmission oil? You could smell it in exhaust fumes.
My main suspect would be crank seal, as KTM-5 suggested.

|

2/4/2019 8:52 PM

UPDATE: It is the crank seal. At least that’s what I’m going with because everything else is fine. Runs great so I don’t think it’s a betting issue. The good news is I was under the impression that I had to split the cases, but I don’t.

|

2/4/2019 8:52 PM

Thanks for the replies

|

2/4/2019 9:00 PM

Yup way too much oil for jetting

|