21’ 250sxf trouble shooting...?

Related:
Create New Tag

10/31/2020 8:57 AM

Have a built 21 250sxf with only 4hrs on it.
Ran amazing for the first 2-3hrs then next time I pulled it out it made great/amazing bottom end power say 5-6krpm and less then everything above that felt like it wasn’t getting fuel or something?. Maybe 25-30hp max vs a 50hp engine. I have a new rmz 250 stock to compare against as an emergency bike and the ktm is major down everywhere past 5k so somethings major wrong.

I was I thinking that it might be fuel filter in the tank so I sliced it open and it looked good. I decided to spend the money and just replace the entire fuel pump and filter assembly in the tank anyways if it was a pack of fuel problem.
Well that made zero change
I also put the stock ecu back in the bike incase the GET ecu was faulty but it ran worse w stock ecu and had same problems.


Bike is maintained like an F1 car so oils and filters are always clean every ride etc bike always has fresh fuel too. not sure what it can be.

Please help

|

10/31/2020 2:07 PM

Bad fuel
Injector
Any smoke?-poss broken ring
Any backfiring?

|

10/31/2020 6:49 PM

Factor E wrote:

Bad fuel
Injector
Any smoke?-poss broken ring
Any backfiring?

changed fuel just incase and thats not problem.
changed inline fuel filter as well perfectly clean
no smoking
no backfiring


not sure how to check fuel injector, it starts idles, revs cleanly and up to 5-6kish it makes wicked power so i doubt the injector is clogged up?

Could be an air temp or other sensor be bad?

|

10/31/2020 7:49 PM

Factor E wrote:

Bad fuel
Injector
Any smoke?-poss broken ring
Any backfiring?

dbx33 wrote:

changed fuel just incase and thats not problem.
changed inline fuel filter as well perfectly clean
no smoking
no backfiring


not sure how to check fuel injector, it starts idles, revs cleanly and up to 5-6kish it makes wicked power so i doubt the injector is clogged up?

Could be an air temp or other sensor be bad?

Pull injector...
With a 9v, take a couple wires and build a set of pigtails that you can attach to the injector. When touched, the injector will open, back flush with air and contact cleaner...

Check all sensors and connections too.

|

11/1/2020 4:19 AM

Check all electrical connections
Does problem start after warming up?
Change plug and check boot

|

11/1/2020 5:19 AM

Check your TPS sensor.
Check your fuel pump pressure.

Paw Paw

|

11/12/2020 5:12 PM

changed to a whole new fuel pump assembly and filter. no change. TPS hasn't changed and adjuster bolt is tight no play or voltage varying when trying to wiggle it.

|

11/12/2020 6:43 PM

Fuel filter line kinked in the gas tank?

|