2018 KX450 TAC Help

Related:
Create New Tag

5/21/2018 10:30 AM
Edited Date/Time: 5/21/2018 10:31 AM

Just picked up a 2018 KX450. I have yet to ride the bike, while trying to get the forks set up I have run into a problem and cant find anything on the web. The balance chamber is not holding air. No idea what is going on? I have used two different pumps so I know it is not a pump issue. Has anyone else seen this? Like I said I cant find anything on the web so hopefully someone can help.

Thanks in advance.

|

5/21/2018 10:44 AM

If you haven't ridden the bike yet, I would take it back

|

5/21/2018 10:54 AM

That is what I very well might end up doing. But that will mean driving 3.5 hours each way, so I was hoping it would be an easy fix.

|

5/21/2018 10:58 AM

Spray some fluid where you put air in and see if its leaking.

|

5/21/2018 11:09 AM

Motobeau179 wrote:

That is what I very well might end up doing. But that will mean driving 3.5 hours each way, so I was hoping it would be an easy fix.

If its a factory issue,any kawy dealer with fix it.

|

5/21/2018 4:19 PM

Check the schraeder valve, if that's not it, take it back as it's probably an oring which requires full disassembly.

|

Livin' the dream, two wheels at a time!

5/21/2018 4:40 PM

I was planning on doing the Race Tech spring conversion after a few hours on the bike. After going back and forth with the dealer I sent the forks off today and will have them back Friday. Thanks for the replies.

And thanks to Ronnie at Six12 suspension, good guy to talk to and very helpful. Anyone in FL needing Race Tech services give him a call. http://www.six12suspension.com

|