2017 ktm 350 completely dead, no electrical power

Related:
Create New Tag

1/3/2018 6:28 PM

I was riding today and my bike just died on a straight going wide open. Motor turns over and everything but it has no spark, the starter is dead, and the FI light doesn't even come on when bump starting. My friend said something about a fuse but if it's that how do I make sure it doesn't happen again? Has anyone had similar experiences? Bike has 131 hours of hard B class moto on it.

|

1/3/2018 7:00 PM
Edited Date/Time: 1/3/2018 7:03 PM

Have you checked the battery?
What does the voltage show no load?
Voltage under a load?
Have you checked the battery wire connections?
Have you checked the fuse?
Have you checked the starter relay?
Have you checked the kill switch?

Paw Paw

|

1/3/2018 7:23 PM

Take Paw Paw's advice - get a service manual and a multi-meter... you'll learn a lot.

|

Positively, absolutely 110% obsessed with anything MOTO.

1/3/2018 9:38 PM

Check the white plug behind the numberplate. I dont know if this would prevent it from not being bump started. That broke on mine and woundn't start. Had other wires come dissconected under the tank too when doing the top end but that was from moving them around.

|

1/3/2018 9:44 PM

Subframe bolts loose?

|

Tomac and/or Anderson for 2020.....

1/4/2018 1:15 AM

I had two batteries fail on my 17' 350 and it sounds like the same symptoms you have.

Replace it with an Antigravity and forget about it.

|

1/4/2018 11:31 AM

I had the fuel line partially disconnect while riding, bike went dead. Reconnected it and no problem.

|

1/4/2018 3:57 PM

The relay in the air boxPhoto

|