2016 rmz450 problems

cody341
Posts
108
Joined
5/20/2010
Location
R, TN US
11/19/2017 8:31pm
hey I have rmz450 with 32 hours on it motor is all stock never been into. take very good care of it.

the last two times I've been riding it with sputter and pop off idle, but only for the first 20 mins. Then its gone. Just curious if anyone has had experience with this or could give me suggestions.
|
Rotaholic
Posts
1367
Joined
4/2/2013
Location
NZ
11/19/2017 8:40pm
The plug where the fuel pump meets the loom is corroded, has happened on every RMZ I have seen.
cody341
Posts
108
Joined
5/20/2010
Location
R, TN US
11/19/2017 9:40pm
Rotaholic wrote:
The plug where the fuel pump meets the loom is corroded, has happened on every RMZ I have seen.
The plug where the fuel pump meets the loom is corroded, has happened on every RMZ I have seen.
whats the loom?
Rotaholic
Posts
1367
Joined
4/2/2013
Location
NZ
11/20/2017 2:17am
When you take the Petrol tank off, on the left hand side there is two black plugs, one is connected to the wiring that goes back to the fuel pump, one connects to the wiring loom on the frame. The male and female pins inside those two black plugs rust and make very poor contact. Replace them with new connectors and be careful when washing the bike not to hit that area to hard with the jet wash.
Dylan844
Posts
9
Joined
9/13/2016
Location
Wisconsin Rapids, WI US
11/20/2017 7:24pm
When's the last time you checked valves? Just a thought. I have owned 4 rmz's and have not run into that fuel pump conector problem yet however that could be a possible cause as well

The Shop

weland28
Posts
53
Joined
2/22/2017
Location
Eagle Grove, IA US
11/20/2017 7:34pm
Definitely sounds like valves 32 hours is quite a bit with out checking them. It’s probably going away after 20 minutes because they’re getting hot and expanding and making the seal better, probably just need some new shims.
cody341
Posts
108
Joined
5/20/2010
Location
R, TN US
11/20/2017 10:10pm
I pulled the tank and the connectors looked like new. I will check the valves tomorrow but I wouldn't think they would be out of spec. I buy a new bike every year and haven't ever had to touch the valves and my last one had over 200 hours. I might be wrong, we shall see
11/20/2017 11:35pm
My 2011 RMZ has done about 250 hours, has never needed any shims changed as yet, still has as much comp through the kick lever as it had when new. Sometimes my bike displays those symptoms that you describe when I run a high octane fuel without swapping to the rich connector (the grey one).

Yours sounds a touch lean; no air leaks around the inlet manifold?
11/21/2017 12:09am
Im not saying it's not valves, but I have had two Rmz450's that had done over 200hrs and never had valve adjustment or top ends for that matter. They never gave any trouble other than the wiring loom that rotaholic was talking about.
11/25/2017 1:23pm
the rmz seems to bee a relly relieble bike now days.
Badd127
Posts
493
Joined
12/2/2016
Location
SE
11/30/2017 6:02am
Did you find the problem with the bike?

Have you tried reseting the TPS?

I had a similar problem with my 16 rmz450, coming out of slow corners, when getting on the throttle it would hesitate or splutter a bit. It was more noticeable on slow seeping corners, as a consistent low throttle.
I never found the problem, it wasn't noticeable when I was riding the bike hard, in racing or serious practice.
I was going to reset the TPS. But before I got the chance to, I changed to a vortex ignition and yoshimura exhaust, I haven't noticed it since.

Post a reply to: 2016 rmz450 problems

The Latest