2016 ktm 250sxf. No spark and no power to fuel pump.

Related:
Create New Tag

8/11/2018 12:17 PM

I checked both the fuses next to the relay. The relay clicks but I know that doesn’t always mean it’s good. Is there anyway to test it? The motor turns over and battery is good. Checked connections and grounds. Thanks!

|

8/11/2018 12:54 PM

Load test the battery.
See what the battery voltage is under a load.

Paw Paw

|

8/11/2018 1:21 PM

Heading to my work to use the load tester soon. Will a bad battery really be able to turn the motor over but not give any power to the fuel pump and no spark?

|

8/11/2018 1:53 PM

Is it givng any codes?

|

8/11/2018 2:11 PM

Mitchell_Wicklund wrote:

Heading to my work to use the load tester soon. Will a bad battery really be able to turn the motor over but not give any ...more

Definitely Will

|

8/11/2018 2:20 PM

The FI light doesn’t come on at all

|

8/11/2018 2:46 PM

Mitchell_Wicklund wrote:

Heading to my work to use the load tester soon. Will a bad battery really be able to turn the motor over but not give any ...more

Yes. It can have enough juice for some things and not others.

|

8/11/2018 2:47 PM

Did u check the wire connection behind the front number plate?

|

8/11/2018 3:04 PM
Edited Date/Time: 8/11/2018 3:07 PM

Do you guys know the CCA for the WPS featherlite batteries? There’s nothing by volts on the battery. Tester is saying 95cca

|

8/16/2018 3:25 PM

Update: Did a load test on the battery after finding the correct CCA’s for the battery in my bike and it failed. I also tested the relay and it had a bad coil. Replaced both of them and the bike fired right up. I also replaced both of the fuses because the plastic cover had a small crack and created some corrosion on the fuse. Thanks again!

|