2016 Ktm 450 SXF bog off idle

Related:
Create New Tag

7/12/2018 4:43 AM

Currently my bike will fire up and idle for about 25 seconds and then die. If you hit the throttle to rev it up it will bog and die. If you slowly get it up off idle the bike will rev up but once back to idle it will die again. I'm fortunate enough a buddy of mine has let me try about every part off his bike to see if it is any electrical parts and so far nothing has changed it. I have tried adjusting the TPS sensor and it doesn't help either. The bike started acting up during a practice day but was running fine. It almost seemed like the bike was starving for fuel. I have replaced the injector and tried my buddies tank and still didn't change anything. Has anyone experienced the same thing or have any insight on where to go from here?

|

7/12/2018 4:55 AM

Wheres your idle at? A lot of people are happy with 2000-2100 rpm. Any lower youll have issues. Also could be a fuel pump or injector problem

|

7/12/2018 6:43 AM

Replace all the fuel filters?

|

7/12/2018 7:08 AM

sandman768 wrote:

Replace all the fuel filters?

If he tried the other fuel tank I think that would cover the filters.

Hummmm? Air filter clean?

|

7/12/2018 9:26 AM

sandman768 wrote:

Replace all the fuel filters?

CarlinoJoeVideo wrote:

If he tried the other fuel tank I think that would cover the filters.

Hummmm? Air filter clean?

You would think so, but wonder about the small one in the fuel line.

|

Take it to the limit, one more time!

7/12/2018 9:38 AM

sandman768 wrote:

Replace all the fuel filters?

CarlinoJoeVideo wrote:

If he tried the other fuel tank I think that would cover the filters.

Hummmm? Air filter clean?

mx317 wrote:

You would think so, but wonder about the small one in the fuel line.

That's what I was thinking ...they are very small & does not take much to restrict fuel flow...

|

1/6/2019 4:28 PM

jg622 wrote:

Currently my bike will fire up and idle for about 25 seconds and then die. If you hit the throttle to rev it up it will bog ...more

Were you able to fix the problem and if you did what was the issue ?

|