2015 YZ125 bogging with 32:1 mix

Related:
Create New Tag

3/19/2018 6:19 AM

One of my new riding buddies has a 2015 YZ125 and yesterday at the track, after hearing him ride, I told him the bike just didn't sound right when it got on the pipe.. Way too fat and boggy. I asked what ratio he was running and he said 32:1, which he said that's what the bike calls for (I haven't confirmed this).. He's the second owner of the bike and is 99.9% sure the previous owner wouldn't of even known how to re-jet the bike, so we're assuming the carb settings are all stock.

I know oil ratio and jetting specs run hand in hand.. but if the carb settings are indeed stock, and the manual does call for 32:1... where's the best place to start? Try leaning it out with the clip setting? Any comments are much appreciated. Thanks guy

|

Positively, absolutely 110% obsessed with anything MOTO.

3/19/2018 6:26 AM

Ive always been told to run the specified mixture ratio and jet accordingly. First step is to see what jets you have and compare to the stock ones.

|

3/19/2018 6:59 AM

Might have too big of a main jet. My 2006 YZ125 has all stock jetting with the air screw at two turns. I run 32:1 and no bog, wheelies out of corners.. Best thing to do is just take the carb off and check out what jets are in it.

|

3/19/2018 7:00 AM

Also, the manual actually calls for 30:1 I'm pretty sure. I've even tried that and no bog either.

|

3/19/2018 7:37 AM

Like it has been stated, the issue is not the oil mix ratio.
Take the carb apart and clean all the passages and jets.

|

3/19/2018 9:56 AM

Definitely not mix ratio related. I have gone up to 20:1 in a YZ125 and it ran great.

|