2010 crf 250r fires but dies

Related:
Create New Tag

10/31/2018 5:21 PM

2010 crf 250r good spark valves all in spec good compression good fuel/fuel flow cam timing is dead on checked at all 3 points (fly wheel, crank,andcam) all marks line up perfect bike won’t stay running and is hard to start will start occasionally no dtcs flashing on MIL will die when high idle is clicked off ???? Possible capacitor?

|

10/31/2018 6:03 PM

When you turn off the high idle youre taking air away. So your default fuel mixture is too rich for the bike. I suggest you make sure your air filter is clean and isnt over oiled. If thats okay, im putting my bets on a bad temperature sensor throwing off the mixture. This is assuming it does actully run with the high idle knob and your valves arent leaking.

|

10/31/2018 6:14 PM

I watched the valves as I rotated the engine over with the valve cover off everything is smooth none of them seem to be sticking clearances are in spec air filter is clean and it will start and run every x amount of kicks however it fires just about every kick performed spark test and spark was consistent and good color when you say temperature sensor are you talking about coolant temp or intake air temperature sensor ?

|

10/31/2018 6:53 PM

When you click off the high idle, you are takings fuel away, not air as previously suggested. Thus you are starving for fuel. Either a clogged fuel filter or a bad fuel pump. Normally the sensors mentioned can cause problems too, but most likely your fuel supply is being restricted.

Paw Paw

|

11/1/2018 7:31 AM

Wyatt_MacAlister wrote:

I watched the valves as I rotated the engine over with the valve cover off everything is smooth none of them seem to be sticking clearances are in spec air filter is clean and it will start and run every x amount of kicks however it fires just about every kick performed spark test and spark was consistent and good color when you say temperature sensor are you talking about coolant temp or intake air temperature sensor ?

Either sensor can throw off the mixture. I had the same issue on my kx450f and it was the coolant sensor. But make sure your valves arent leaking via leak down test.

|

11/3/2018 9:59 PM

i had the same issue with my 2013 crf250r
check the condenser connection mine was full off dirt and crap after 15hrs
simple solution was clean it and then tap it up with electrical tap had no issues after that

|

11/4/2018 10:20 PM

Paw Paw 271 wrote:

When you click off the high idle, you are takings fuel away, not air as previously suggested. Thus you are starving for fuel. Either a clogged fuel filter or a bad fuel pump. Normally the sensors mentioned can cause problems too, but most likely your fuel supply is being restricted.

Paw Paw

+ 1 on this. We see this a lot, more so on street bikes but the symptoms are the same. I believe the fuel pump filter can be replaced but if you take it apart to find its not dirty it may be a faulty pump.

|