17' TC250 Jetting Help

Related:
Create New Tag

11/5/2017 8:09 AM

Has anyone nailed jetting specs for the 17' Huskatoom TC250? I have been hitting Pala in Socal which is about 500' above sea level and temps are pretty steady at 70*F right now. Bike is blubbery down low but crisp mid and up. I checked my float level which is 6-7mm per Mikuni spec and I dropped the pilot from 42.5 to 40 but it didn't do much. Plug reading was dark and sooty at end of the day. Air screw not doing very much. Going to drop to a 37.5 pilot today and up the main to 450 to make up for it. I have read some folks adjusting float to 8-9mm. Does that work? I have also read about correcting squish which seems to help with jetting issues down low. Reed cage looks good btw.

|

11/5/2017 11:47 AM

sea level east coast
37.5 pilot, rest oem bike runs like a raped ape
will post pic of plug for reference
i have run as low as 32.5 pilot, guys I know @ track run 27.5 pilot w/stock needle and main, again bikes run great

|

11/5/2017 11:52 AM

Photo

|

11/5/2017 2:00 PM

what oil ratio are you running? i was having issues at 40:1, then ran the recommended 60:1 and it cleaned it up dramatically.

|

11/5/2017 2:28 PM

opyguy wrote: Photo

That looks damn close...I like my plugs bit more moist and lighter. I'll keep going leaner on the pilot.

|

11/5/2017 2:28 PM

rollin64caddy wrote:

what oil ratio are you running? i was having issues at 40:1, then ran the recommended 60:1 and it cleaned it up dramatically.

60:1 with Bel Ray H1R

|

11/6/2017 4:23 AM

"I like mine a bit more moist and lighter"...sounds like me looking for a girl in college
60:1 motorex

|

11/6/2017 9:08 AM

opyguy wrote:

sea level east coast
37.5 pilot, rest oem bike runs like a raped ape
will post pic of plug for reference
i have run as low as 32.5 pilot, guys I know @ track run 27.5 pilot w/stock needle and main, again bikes run great

Dang,
Mine never ran correctly with these same same settings... i even went down to 32.5
I'm at sea level too/east coast

The 17 KT/HVA seem to be a hit or miss for jetting
Almost threw the towel with my TC until I ditched the TMX for a Keihin PWK. Solved all jetting issues

Best TMX setup was either 37.5 pilot/Stock needle clip 1 and stock main or JD blue #3 , 32.5 PJ and 420 main
My complains with the TMX was the lack of consistency and some rich/lean spots
Any weather change (temp/humidity) and it would run like crap

Opyguy, mind sharing your PV settings ? (Spring color and how many turns in form fully backed out)

I ran the red at 1-3/4 for a while and now back to yellow at 1-1/4
50:1 Maxima K2 with non ethanol fuel

|

11/6/2017 10:43 AM

MXSTATE:
when I ran the jd kit I had a ridiculous hanging idle, even w/blue needle #4, went back to stock w/37.5 pilot.\

I RUN YELLOW POWERVALVE 2 TURNS IN ON HARDPACK AND 2.5 IN ON SAND, if I run PV too far out in sand the engine bogs. Also run a 304 silencer (not shorty).

|

11/6/2017 10:54 AM

My recipe:

Adjust float.

Check reeds for sealing (may not really matter anyways).

Have 0.020" cut off of head.

I have the blue JD needle (#3), 420 main, and 27.5 pilot.

Bike runs great on 93 octane mixed at 32:1.

|

11/6/2017 11:06 AM

erik_94COBRA wrote:

My recipe:

Adjust float.

Check reeds for sealing (may not really matter anyways).

Have 0.020" cut off of head.

I have the blue JD needle (#3), 420 main, and 27.5 pilot.

Bike runs great on 93 octane mixed at 32:1.

What did you adjust float to? I'm at recommended Mikuni setting of 6-7mm. Lots of folks are talking about adjusting the float but I haven't seen anyone offer a range that worked.

|

11/6/2017 11:09 AM

opyguy wrote:

MXSTATE:
when I ran the jd kit I had a ridiculous hanging idle, even w/blue needle #4, went back to stock w/37.5 pilot.\

I RUN YELLOW POWERVALVE 2 TURNS IN ON HARDPACK AND 2.5 IN ON SAND, if I run PV too far out in sand the engine bogs. Also run a 304 silencer (not shorty).

I have my PV at 2.5 out with the standard spring and I kind of felt like it was boggy down low and not in the jetting sense. I also have a 49T rear sprocket so maybe I need to go back in on the PV.

|

11/6/2017 11:21 AM

erik_94COBRA wrote:

My recipe:

Adjust float.

Check reeds for sealing (may not really matter anyways).

Have 0.020" cut off of head.

I have the blue JD needle (#3), 420 main, and 27.5 pilot.

Bike runs great on 93 octane mixed at 32:1.

sdhuskyrider wrote:

What did you adjust float to? I'm at recommended Mikuni setting of 6-7mm. Lots of folks are talking about adjusting the float but I haven't seen anyone offer a range that worked.

Pretty sure I adjusted to between 8.5 mm and 9 mm. It works out to where the float is just parallel to the bowl mounting surface when the fuel needle has just seated.

The head mod really cleaned things up for me.

|

11/6/2017 12:00 PM

opyguy wrote:

MXSTATE:
when I ran the jd kit I had a ridiculous hanging idle, even w/blue needle #4, went back to stock w/37.5 pilot.\

I RUN YELLOW POWERVALVE 2 TURNS IN ON HARDPACK AND 2.5 IN ON SAND, if I run PV too far out in sand the engine bogs. Also run a 304 silencer (not shorty).

sdhuskyrider wrote:

I have my PV at 2.5 out with the standard spring and I kind of felt like it was boggy down low and not in the jetting sense. I also have a 49T rear sprocket so maybe I need to go back in on the PV.

I plan on going to a sandy track tomorrow or Wednesday, I will run PV @ 2 and then 3 in to give u a comparison of the variance.

|

11/6/2017 12:21 PM

opyguy wrote:

MXSTATE:
when I ran the jd kit I had a ridiculous hanging idle, even w/blue needle #4, went back to stock w/37.5 pilot.\

I RUN YELLOW POWERVALVE 2 TURNS IN ON HARDPACK AND 2.5 IN ON SAND, if I run PV too far out in sand the engine bogs. Also run a 304 silencer (not shorty).

sdhuskyrider wrote:

I have my PV at 2.5 out with the standard spring and I kind of felt like it was boggy down low and not in the jetting sense. I also have a 49T rear sprocket so maybe I need to go back in on the PV.

With the JD setup, I also had the hanging idle and never been able to get rid of it.

I found that with all springs adding more than 2 ~2 1/2 turns never worked well. Bike would either bog down low or hit like a mule at the worst moment .

Between flush and 1-3/4 in works best for me (but that’s just me , practice wonder only ..)
Now that I don’t have to spend hours with jets and needles , I can fine tune with the PV and will also try soon a flywheel weight
One thIng I noticed is that even going to a 49 rear sprocket, the bike works best when short shifted.

|

11/6/2017 12:58 PM

erik_94COBRA wrote:

Pretty sure I adjusted to between 8.5 mm and 9 mm. It works out to where the float is just parallel to the bowl mounting surface when the fuel needle has just seated.

The head mod really cleaned things up for me.

Yea I am sold on head mod. Going to do that this week. The only bummer is having to run 100 octane for me. We only get 91 octane here in California and the closest I can get to decent fuel locally without having to buy it in a can is VP 100 octane street blaze. I run it in all my limited SXR 800 anyway.

|

11/6/2017 4:28 PM

Anyone know the stock setting for the PV?

|

11/6/2017 6:55 PM

mine was 3.25 in from full out, documented as soon as I brought bike home

|

11/6/2017 8:13 PM

I sent a head out to get milled and it may be back on the bike this weekend. Ill give you a ride report from pala with stock jetting on the milled head.

|

11/6/2017 8:16 PM

rollin64caddy wrote:

I sent a head out to get milled and it may be back on the bike this weekend. Ill give you a ride report from pala with stock jetting on the milled head.

What day are you going? I'll probably go Saturday and Sunday since the Raiders are on a bye.

|

11/7/2017 2:21 PM

I'm hoping saturday. I had an issue with the schrader valve in the forks leaking last weekend so i have to get that fixed also.

|

11/7/2017 3:00 PM
Edited Date/Time: 11/7/2017 3:03 PM

rollin64caddy wrote:

I'm hoping saturday. I had an issue with the schrader valve in the forks leaking last weekend so i have to get that fixed also.

Cool I'll be there. Look for the silver Toyota 4Runner with the big Raiders sticker in the back window. I'll be at the vet track trying to get the hang of this rocketship.

Has anyone tried an RK Tek head? I saw some pics floating around and it seems the OEM KTM/Husky head has almost no squish band. Not the best design.

|

11/9/2017 7:03 PM

sdhuskyrider wrote:

Cool I'll be there. Look for the silver Toyota 4Runner with the big Raiders sticker in the back window. I'll be at the vet track trying to get the hang of this rocketship.

Has anyone tried an RK Tek head? I saw some pics floating around and it seems the OEM KTM/Husky head has almost no squish band. Not the best design.

just got the head back on and fixed the issue with my forks. i'll definitely be at pala Saturday barring a catastrophe, ill keep an eye out for ya.

not sure about the rk head but If its like the slavens, I think its designed to accommodate people who ride in higher altitudes like 8000+ft. don't quote me on that though.

|

11/10/2017 4:58 AM

opyguy wrote:

MXSTATE:
when I ran the jd kit I had a ridiculous hanging idle, even w/blue needle #4, went back to stock w/37.5 pilot.\

I RUN YELLOW POWERVALVE 2 TURNS IN ON HARDPACK AND 2.5 IN ON SAND, if I run PV too far out in sand the engine bogs. Also run a 304 silencer (not shorty).

sdhuskyrider wrote:

I have my PV at 2.5 out with the standard spring and I kind of felt like it was boggy down low and not in the jetting sense. I also have a 49T rear sprocket so maybe I need to go back in on the PV.

rode yesterday, sandy track. originally @ 2 turns in, slight bog down low, went to 2.5 in and bog went away, for what its worth, i feel like I can run PV further out on hardback but it needs to be turned in more for sand.

|

11/10/2017 5:00 AM

rollin64caddy wrote:

I'm hoping saturday. I had an issue with the schrader valve in the forks leaking last weekend so i have to get that fixed also.

what happened? I ride 1.5 hours yesterday to get to the track, got there, set my air pressure and forks wouldn't hold pressure, definitely leaking (fast) @ the schrader valve. I got lucky, someone had one and I just replaced it, was able to ride, but it worries me. lml what you end up doing for fix

|

11/10/2017 7:01 AM

rollin64caddy wrote:

I'm hoping saturday. I had an issue with the schrader valve in the forks leaking last weekend so i have to get that fixed also.

opyguy wrote:

what happened? I ride 1.5 hours yesterday to get to the track, got there, set my air pressure and forks wouldn't hold pressure, definitely leaking (fast) @ the schrader valve. I got lucky, someone had one and I just replaced it, was able to ride, but it worries me. lml what you end up doing for fix

Had this same problem on my 16.5 450 FE air forks...I just used an old valve from an inner tube! Happened at Southwick one day....I was pumping them forks like a madman to get the pressure back! Bought cone valves the next day ...have had the cone valves on my 18 250 Sx since new, just for comparison I ran the stock airs last week at my local practice track as I sent my conevalves out for service......instant arm pump........I think my 18 has the same jetting as the 17"s, I"m 1 step leaner on the pilot, stock needle on 3 rd clip, 2 steps richer on the main, 450 In warmer temps I will try 2nd leaner pilot. Fmf fatty & standard silencer, 50/50 race gas & non ethanol @ 50:1...I set my gearing & powervalve same as MXA suggest, bike rips, but a lot more work than a 450!

|

11/10/2017 7:26 AM

rollin64caddy wrote:

I'm hoping saturday. I had an issue with the schrader valve in the forks leaking last weekend so i have to get that fixed also.

opyguy wrote:

what happened? I ride 1.5 hours yesterday to get to the track, got there, set my air pressure and forks wouldn't hold pressure, definitely leaking (fast) @ the schrader valve. I got lucky, someone had one and I just replaced it, was able to ride, but it worries me. lml what you end up doing for fix

I took a valve out of a tube i had in the garage. I set pressure at 150 and checked it 24 hrs later with no pressure loss. Im gunna call it good.

|

11/10/2017 8:40 PM

I'm guessing there might have been a little dirt in you pump and maybe got blown into the Shrader valve.

|

The older I get, the faster I was.

11/11/2017 10:05 AM

Pulled out my reed cage for a better look....its not good. Trying to track down a VForce reed cage today. No wonder the jetting is shit.Photo

|

11/11/2017 1:58 PM

Something else I noticed today....the bike came with half of the gear oil it called for!?!! Check your oil if have a new bike and haven't done an oil change.

|