08 YZ 125 3/4 to FT won't rev out.

Related:
Create New Tag

6/17/2018 7:12 AM

My son's Yz125 won't rev out and breaks up at 3/4 to Full throttle. This unfortunately happened at the all-star race at high point. It ran well without the humidity, Lowered main to 400 and raised clip to top on needle. It got better but still wouldn't go. Any help would be appreciated.

|

6/17/2018 9:44 AM

Im sure its jetting related because of the humidity you mentioned, but i have seen bikes not rev out due to a bad plug or incorrect plug gap.

|

6/17/2018 7:23 PM

What exactly is it doing?

|

Tomac and/or Anderson for 2020.....

6/17/2018 8:29 PM

Open resistor spark plug cap will do this. Should measure about 5k ohm when removed.

|

6/18/2018 4:46 AM
Edited Date/Time: 6/18/2018 9:49 AM

Bob,

Builds and sounds crisp until I put it full throttle, then it breaks up.

Chill,

Gonna meter all ignition now.

Thank You

|

6/18/2018 11:42 AM

Went through ignition specs. Only out of spec reading is primary ignition coil. Spec is .24 -.36 OHMS. Mine is reading .5 ohms. What do you think?

|

6/18/2018 12:57 PM

Sounds like you got a bad coil. Too much resistence for a supplied voltge will result in a weak or no spark

|

6/18/2018 4:50 PM

Had the coil do the same thing on a KTM105SX. Hopefully you have buddy with a YZ125 so you can try it b4 you buy one.

|

6/18/2018 5:07 PM

chillrich wrote:

Had the coil do the same thing on a KTM105SX. Hopefully you have buddy with a YZ125 so you can try it b4 you buy one.

I don't but i'm going to clean off the contacts on the coil and ground and see if the reading changes.

|