Yami 125 idles, but when givin throttle, dies. It's a 4 stroke, take it easy with the jokes

Related:
Create New Tag

6/10/2017 7:12 PM

It was running fine and litterally died on the spot. It was very low on oil so I gave it some and let it idle and it ran fine the first 50 seconds and then went back to the same problem. Please help, take it easy with the 2 stroke jokes

|

6/10/2017 7:18 PM

Clean the carb bro

|

Alright Lunger, Let's Do It

6/10/2017 8:54 PM

And the air filter.

|

6/10/2017 9:02 PM
Edited Date/Time: 6/10/2017 10:20 PM

Does it have gas? Dont mean that sarcastically. It happens to the best of us, at one time or the other.

When you said you "gave it some oil", what does that mean?

|

much ty. How to spot a paid forum poster/artificial forum traffic producer (see list of actions/phrases below):

Copius pattern amounts of phrases like “Anyone have”..., “Anybody know?”.... and their variations.

Thoughts?
Any help is appreciated!
Thanks in advance!





6/10/2017 9:03 PM

Are your sprocket bolts torqued to spec?

|

Instagram: vanillaice782
Amateur helmet painter

6/10/2017 9:27 PM
Edited Date/Time: 6/10/2017 9:30 PM

Open throttle and pull choke at the same time. Or go to half choke.

If it runs, pilot jet is plugged. Or some other source of fuel is being starved.

If it has a low oil shutoff, make sure its full enough. Because a low oil shutoff kills the ignition. Lots chase a dead engine for days because of that.

|

6/11/2017 3:58 AM

I don't understand the title you've selected for this thread, so I'm going to go with, "Get a cat."

|

6/11/2017 4:07 AM

Try a different colour powerband

|

6/11/2017 5:47 AM
Edited Date/Time: 6/11/2017 5:49 AM

Standard for a Yamaha! They dont like the throttle opened.

Replace with any other brand!

|

6/11/2017 6:04 AM

kzizok wrote:

Does it have gas? Dont mean that sarcastically. It happens to the best of us, at one time or the other.

When you said you "gave it some oil", what does that mean?

Yea it has gas, it was due for an oil change but I rode it anyway which was very stupid...I just changed the oil and let it cycle in idle for about 5 mins and at first it was fine, then it went back to bogging with throttle

|

6/11/2017 6:53 AM

I got it! I cleaned the carb and air filter. Thanks for all the comments!

|