2018 Yamaha YZ450F stops mid moto

Related:
Create New Tag

7/21/2020 8:14 AM

Anyone out there that has ever had this happen before? 2018 Yamaha YZ450F. Starts right up, runs fine, mid moto the bike dies, pull off track and starts right back up. This happen two weeks ago a couple of different times so I pulled the kill switch off of it. Thought it was fixed as it was ridden 6 different times since then with no issues, doing 2 20 minute moto's each day along with working on starts and then today it happens again. Any thoughts???

|

7/21/2020 8:25 AM

Those yamis have a ton of problems.
I wouldn't use a bike that randomly stops mid-moto, imagine it stopping right on the face of a jump.
No, thanks, i'm selling the bike and getting a kawi/ktm.

|

rarararaataatatatata

7/21/2020 8:36 AM

I'd keep a finger on the clutch if i were you. You may be able to have a dealer plug it in and check for codes/ run diagnostics.

|

7/21/2020 8:54 AM

MZ193 wrote:

Those yamis have a ton of problems.
I wouldn't use a bike that randomly stops mid-moto, imagine it stopping right on the face ...more

do you ever have anything helpful to add?

|

7/21/2020 9:04 AM

MZ193 wrote:

Those yamis have a ton of problems.
I wouldn't use a bike that randomly stops mid-moto, imagine it stopping right on the face ...more

I think it's more along the lines of that Yamaha sells so many of those bikes that you see more problems.

|

7/21/2020 9:07 AM
Edited Date/Time: 7/21/2020 12:01 PM

Clogged up fuel injectors maybe??? I always purchase the Twin Air filters that go inside the fuel tank for this reason. You don’t realize the fine dust particles that accumulate in your gas can.
Also check to make sure the fuel line is not pinched or twisted. It sounds simple but I have had this happen before.

|

7/21/2020 10:40 AM

My 250yzf did this a few races recently. Mine was the coil had a loose connector on the end of it.

|

7/21/2020 11:34 AM

I've had this happen to my 18 at a sand track. Getting bad starts with close to full gate, you get a lot of roost from 450s. The roost goes right into the airbox, the way the shroud design is. The air filter gets dirty easily. Had to pull off at the end of the moto from mine dying on me too.

|

7/21/2020 11:42 AM

The last time i had something similar it was a plugged vent on the gas cap. Sometimes the metal ball in the one way check valve corrodes and blocks flow. Or dirt can plug the rubber vent line. Take the gas cap of and make sure you can suck air through the vent line, when you flip the cap upside down the air flow should stop.

|

7/21/2020 11:43 AM

This happened to me but it was a bad fuel pump.

|

Not much to say to Vitards.

7/21/2020 11:50 AM

rryker wrote:

Anyone out there that has ever had this happen before? 2018 Yamaha YZ450F. Starts right up, runs fine, mid moto the bike dies, ...more

Check vent line on gas cap. Sounds like you are restricting fuel flow to the engine

|

7/21/2020 1:40 PM

I believe you can use your app to check for codes instead of taking it to the dealer.

|

7/21/2020 2:17 PM

My 18 yz250f would do the same thing. Vent hose was plugged with dirt and old gas

|

7/21/2020 3:09 PM

We had two 18 450s. We had the same problem with both bikes. I changed the stator, harness, pump, battery, kill switch, condenser, and starter relay. Never fixed it. That combined with the transmission lasting an average of 10 hours each left a bad taste for Yamahw 450s. Our 19 and 20 250s have been solid

|

7/21/2020 4:05 PM

MZ193 wrote:

Those yamis have a ton of problems.
I wouldn't use a bike that randomly stops mid-moto, imagine it stopping right on the face ...more

cbarber wrote:

do you ever have anything helpful to add?

Not if it's related to a 2014+ Yzf😂

|

rarararaataatatatata

7/21/2020 4:18 PM

huutnanny wrote:

I believe you can use your app to check for codes instead of taking it to the dealer.

That’s how I found mine

|

7/21/2020 4:54 PM

MZ193 wrote:

Those yamis have a ton of problems.
I wouldn't use a bike that randomly stops mid-moto, imagine it stopping right on the face ...more

cbarber wrote:

do you ever have anything helpful to add?

MZ193 wrote:

Not if it's related to a 2014+ Yzf

Not useful or funny.

|

7/21/2020 5:10 PM

I had a problem with my 16 cutting out after it got hot, would still run just cut out, so a little different than yours, but mine was the spark plug cap

|

7/21/2020 6:25 PM

Jack_Wagon wrote:

We had two 18 450s. We had the same problem with both bikes. I changed the stator, harness, pump, battery, kill switch, ...more

We have (2) '18 YZ450Fs and both have been perfectly rock solid at +70 hours on each. No idea what was going on with yours.

|

7/21/2020 7:25 PM

|

7/25/2020 10:09 PM

This started happening to my neighbors 18 yzf450. Picked up the bike used in excellent condition with 5 original hours on it. Bike was solid for about 15-20 motos of practice then just started dying mid moto for no reason but would always start back right back up. Sometimes it would be fine for 2-3 days with no issues. Checked for loose connections, wire terminal corrosion etc but nothing obvious. Took it to Ponco Regional and it killed once in every moto in 450 C, cost him an overall and finished 2nd, was leading every moto. Finally his dad took it to a reputable shop, they ran test, showed a code and came to the conclusion the tip over sensor in the ECU was malfunctioning causing the problem. The shop even got Yamaha rep to get a new ECU free of charge. After the ECU replacement and no codes showing the bike ran fine at practice for 2 days, on the 3rd day it killed right before a jump face and lucky he was able to save it and not crash. The bike was traded in the next day for a 2020 yzf450 and so far this bike has been reliable.

|