Added reply in a thread Bell Moto 3 Helmets 10/30/2018 1:07 PM

I need new number plate side covers.

Added reply in a thread Bell Moto 3 Helmets 10/30/2018 1:07 PM

Here you go...

... more »
Added reply in a thread Bell Moto 3 Helmets 10/30/2018 7:03 AM

I got to see Marty Smith race at the track in St. Peter’s Missouri back in the 70’s. My brother had a giant poster of him jumping on his Honda from the year he won the championship back in the 70’s.

Added reply in a thread HPI Ignition Systems 10/28/2018 11:41 AM

So, regardless as to the cause of my stock systems failure, all the motorcycle scrap yards wanted 225.00 to 280.00 for a stock stator with no warranty. My HPI system, complete with new flywheel, stator, CDI unit, coil, kill switch and all new wiring ... more »

Added reply in a thread Bell Moto 3 Helmets 10/28/2018 10:47 AM

Yeah, when I used to race this bike, I had an open face red, white and blue Hondaline helmet with Scott goggles and face grill with the requisite duck tape on the visor joint. I haven’t ridden in the dirt on this 1981 YZ125 since 1985. A long time ago! ... more »

Added reply in a thread HPI Ignition Systems 10/27/2018 7:32 PM

My stock system failed.

Started new thread Bell Moto 3 Helmets 10/27/2018 6:07 PM

I have a vintage YZ125 that I restored and needed a new helmet. I saw the Bell Moto 3’s and knew I had to have one. It looks retro, like I want, and it is very comfortable! Well worth it!

This forum thread has 18 replies

Added reply in a thread HPI Ignition Systems 10/27/2018 6:04 PM

I’d get the HPI system. It’s completely new, so you know what you’re dealing with.

Added reply in a thread HPI Ignition Systems 10/26/2018 10:51 AM

That’s why I went with the HPI system. I started with a new Ricky Stator stator, but it would idle and die as soon as you tried to roll on the throttle. I played around with swapping CDI units, etc., with no luck. So, I decided to get all new stuff that ... more »

Added reply in a thread HPI Ignition Systems 10/26/2018 7:28 AM

Mine is a basic unit, not programmable.

Added reply in a thread HPI Ignition Systems 10/26/2018 7:13 AM

Mine is a HPI ignition system. Works great! Purchased from DC Plastics. They have a lot of parts for vintage bikes.

Added reply in a thread HPI Ignition Systems 10/25/2018 8:32 AM

MaxPower will need to respond to that. My HPI ignition works like a champ!

Added reply in a thread HPI Ignition Systems 10/24/2018 6:37 AM

Good to hear!!!

Added reply in a thread HPI Ignition Systems 10/23/2018 6:32 PM

My original stator melted down after restoring the bike. I guess old electrical is bound to fail. I ordered a Ricky Stator stator and it would start, but not run when rolling on the throttle. I bought an extra used CDI unit, it it did the same thing ... more »

Added reply in a thread HPI Ignition Systems 10/23/2018 1:08 PM

Oh yeah!!!

Added reply in a thread HPI Ignition Systems 10/21/2018 4:16 PM

... more »
Added reply in a thread HPI Ignition Systems 10/21/2018 4:14 PM

Here’s some pics.

Started new thread HPI Ignition Systems 10/21/2018 4:13 PM

I just installed a HPI ignition system on my 1981 YZ125H and it runs like a bat out of hell!!! I had used my original electrical system following a restoration project and it melted down on the first ride. Following a Ricky Stator install and a 2nd used ... more »

This forum thread has 34 replies

Added reply in a thread 1981 YZ125H backfires and dies right off of idle. 10/21/2018 4:07 PM

I installed the HPI ignition system and the YZ runs like a bat out of hell!!! I should have ordered this kit, a long time ago!!!

Added reply in a thread 1981 YZ125H backfires and dies right off of idle. 10/16/2018 8:41 AM

Thanks for the input. I believe I am just going to order a complete HPI system to replace everything electrical. This should solve my problem, all together.