Started new thread Original Red 5/23/2017 11:34 AM

Looking for the original red plastic for a 1986 Honda Cr125. I ordered fenders from UFO that fit that year but they are not the same color! The UFO red is RED and the 86 Honda red is more of an Orange Red? Thanks!

This forum thread has 5 replies

Added a new video Holeshot and one lap at MOVMX 5/23/2017 9:23 AM
C138x104

This video has no comments yet

Updated photo album 1986 5/23/2017 6:34 AM
C138_18557388_10212568457990548_3916052413834907392_n

This photo album has no comments yet

Added reply in a thread 1983 CR 125 shifting issue 5/9/2017 7:39 AM

I have an 86 that was acting up this past weekend under holeshot situations ..... wouldn't shift to fourth without completely letting off and clutching it? I did find out I had a little too much oil in there, so hopefully that was it? Other than that ... more »

Added reply in a thread Race Gas? 5/1/2017 4:54 PM

I was able to get some 105 AV gas at the local airport. Not sure if it's leaded or oxygenated or not, but will re-check the jetting as soon as it dries out here in the Midwest! Thanks!

Started new thread Race Gas? 5/1/2017 7:05 AM

After milling the head I want to run race gas instead of pump gas? I know the preferred would probably be VP 110 but I can only find the T4 around here and it says it's for 4 strokes? It says it is 110 octane what's the difference? Would that still be ... more »

This forum thread has 7 replies

Added a comment about slideshow Winners' Circle: Roger DeCoster - 'I think Marvin was more concerned about Ryan's race' 4/30/2017 9:26 AM
C138_winnershighlight

We all know what went down here!

+1 1 0

Members who like this comment

  • Vital MX member Canuckcrawler
    55404 Canuckcrawler /images/default/avatar/c50.png http://www.vitalmx.com/community/Canuckcrawler,55404/all 12/25/16 1 4 4 1

This slideshow has 5 comments.

Added reply in a thread Joey Savatgy Docked to Eighth, Jordon Smith Leads the Points 4/30/2017 9:19 AM

I thought it was suspect that all night the announcers were pointing out how the riders had to return to the track but when Joey did this they turn their head and nothing was said? ,,,,, Emig rode for Kawasaki and doesn't joey train at Carmicheals .....hmmmmmm? ... more »

Added reply in a thread 86 125 Water Usage? 4/22/2017 12:58 PM

Thanks I just ordered one from DC Plastics

Added reply in a thread 86 125 Water Usage? 4/22/2017 12:39 PM

Ok got the bike bike together after the scratches in the head got removed with some 600 grit on a glass table. Fresh gaskets, fired her up and let run for about five minutes occasionally blipping the throttle. No leaks and checked no radiator fluid loss!

... more »
Added reply in a thread 86 125 Water Usage? 4/19/2017 7:06 AM

Got it apart and even more confused? Everything looks good! The Cylinder is clean the Head is clean the side looks brand new along with the water pump, the hoses are new, the radiators are good, so I don't understand what is causing it to run fluid out

... more »
Added reply in a thread 86 125 Water Usage? 4/18/2017 1:59 PM

I know where it is losing it, it goes out the over flow hose. I have tried a stock radiator cap a 1.1 and now a 1.6 and they all have the same results. a 20 minutes ride drops the fluid from the bottom of the cap to the top of the fins.

Added reply in a thread 86 125 Water Usage? 4/18/2017 1:08 PM

If the pump wasn't working wouldn't it get hot REAL quick? The last time I rode it was for about 20 minutes and it didn't get hot but did spew out some fluid. I can't get it apart so I'm putting the Engine Ice in it and riding it. I don't have the time, ... more »

Added reply in a thread 86 125 Water Usage? 4/18/2017 8:50 AM

Sorry I can't help you, they were on the bike when I purchased it.

Added reply in a thread 86 125 Water Usage? 4/17/2017 5:44 PM

Ok I can't get the cover off. Apparently they glued the dam thing on! I've tried heat and even tapping on it with a rubber mallet .... no go! So I can't check the pump right now but the radiators appear to be fine.

Added reply in a thread 86 125 Water Usage? 4/16/2017 8:01 AM

Well the someone replaced the oil drain plug with a custom 7/16" allen head? I was finally able to get it loose and planned on replacing it with a hex head bolt. Nobody has a 9/16" fine thread around here so I'm down until the socket from Snap-On arrives ... more »

Added reply in a thread 86 125 Water Usage? 4/14/2017 7:37 AM

All good advice! A little more info, the clutch cover is an aftermarket from Australia? and the radiators are suppose to be new? The water pump cover is stock. All the Hoses are new and the motor was said to be just rebuilt. The guy is a trusted racer

... more »
Added reply in a thread 86 125 Water Usage? 4/14/2017 5:42 AM

Have not checked jet sizes yet, but last night found out the air screw was set at 1-1/12 and the needle was on the middle notch. I ended up with the air screw at 2 out and the needle at the 2nd from the bottom and it feels pretty strong but still has ... more »

Added reply in a thread 86 125 Water Usage? 4/13/2017 1:43 PM

I have not drained the oil. Bike runs extremely good but seems to be a little rich on the low end, pulls hard on the top end and plug is dark and wet? I will not fill the radiator after the next ride and see if it stays the same. If it doesn't, I will ... more »

Added reply in a thread 86 125 Water Usage? 4/13/2017 7:59 AM

Just picked her up a few days ago!